locked
Can not install Windows Internal Database (WID) - Windows Server 2012 RRS feed

  • Question

  • I have been trying to install Windows Internal Database (WID) as it is required by Windows Server Update Server (WSUS) but at the end of 'Add roles and features' wizard with following error message:

    WID install error

    The server currently holds AD CS, AD DS, DHCP, DNS and IIS roles.

    Wednesday, October 24, 2012 2:40 AM

Answers

  • I solved the install failure of Windows Internal Database

    Steps:

    In Group Policy Management, edit Default Domain controllers policy
    Open Policies, Windows settings, security settings, local policy, user rights assignment
    Edit "Log on As a Service" and uncheck the "Define these policy settings"

    run command as console admin: gpupdate /target:computer 

    Run secpol.msc
    Local policy, User rights assignment
    Edit "log on as a service", add user or group
    Add "IIS_WPG, NETWORK, NETWORK SERVICE, SERVICE

    Install WID 


    Thursday, October 25, 2012 8:41 AM

All replies

  • Same issue for me, when i restart the server the install fails and a rollback is done, ie no WID is getting installed

    Server roles: AD, DNS, DHCP, WDS and IIS

    Wednesday, October 24, 2012 7:42 AM
  • yep having the same problem cant get it to install. Mine has IIS and AD DS, DNS installed and thats it. 
    Wednesday, October 24, 2012 1:55 PM
  • Same problem when trying to use WID for ADFS.
    Wednesday, October 24, 2012 4:56 PM
  • I solved the install failure of Windows Internal Database

    Steps:

    In Group Policy Management, edit Default Domain controllers policy
    Open Policies, Windows settings, security settings, local policy, user rights assignment
    Edit "Log on As a Service" and uncheck the "Define these policy settings"

    run command as console admin: gpupdate /target:computer 

    Run secpol.msc
    Local policy, User rights assignment
    Edit "log on as a service", add user or group
    Add "IIS_WPG, NETWORK, NETWORK SERVICE, SERVICE

    Install WID 


    Thursday, October 25, 2012 8:41 AM
  • Thank you!

    I add "IIS_WPG, NETWORK, NETWORK SERVICE, SERVICE in to Domain controllers policy. After restart a server, WSUS was installed!

    Thursday, October 25, 2012 11:52 AM
  • Thank-you WimanX. It worked for me as well. You are the man.

    One question though. After I install WID do I need to change the setting back?

    • Edited by gen_gen95 Saturday, October 27, 2012 10:14 AM
    Saturday, October 27, 2012 10:13 AM
  • One question though. After I install WID do I need to change the setting back?

    Great that it worked out for you

    What my "solution" does, is that it disabels the all Domain Servers settings for "run as a service", meaning you can/need specify it on each DC on youre Domain

    If you need to revert the setting, just go ahead but remeber to add the Services to the Domain GPO, otherwise WID (and other services) will not start


    This posting is provided "AS IS" with no warranties or guarantees and confers no rights. Whenever you see a helpful reply, click on Vote As Helpful & click on Mark As Answer if a post answers your question.

    Saturday, October 27, 2012 1:09 PM
  • I tried to follow your instructions, but the settings on the local secpol.msc are unchangable. The Add User or Group button is grey and unusable.
    Thursday, November 15, 2012 10:58 PM
  • Maybe a solution: If you already had made some Configs about a User as Service logon, so WID will fail. I moved to my group policy settings --> computer configuration --> windows settings --> security settings --> locale security --> user rights --> logon as service 

    There note all the entries in the box (will be needed later), uncheck the checkbox above the entries. On your Server where you tried to install WID, open a cmd and make a gpupdate /force. After that try to install, for me it worked. After successfull installation, re-enter the entries in the group policy, so every service will run normaly. 

    Hope that helped.

    Bye

    Friday, March 29, 2013 7:47 AM
  • Thank you, WimanX!

    this solution works for me too.

    Sunday, March 2, 2014 11:05 PM
  • I can't add IIS_WPG to the local policy, it doesn't exist in my domain. The rest of the instructions result in success however.
    Thursday, March 6, 2014 5:04 PM