Troubleshooting: Hyper-V W2K3 VM Lost Network Connection

Troubleshooting: Hyper-V W2K3 VM Lost Network Connection

Table of Contents


Problem

Hyper-V VM guest (Windows Server 2003) on a Windows Server 2008 R2 host “randomly” loses network connection.

Symptom

Unable to ping the VM from the host. On login to the VM error message “The system cannot log you on now because the domain <domainname> is not available.”

WLLogonScreen

Restarting the VM appears to solve the problem in the short term, but at some future time it re-occurs.

There are no useful messages in the Hyper-V log “Microsoft-Windows-Hyper-V-SynthNic-Admin.evtx" or the VM Windows Server 2003 system/application event log.

Solution

On the Host: Install the rollup package for the Hyper-V role in Windows Server 2008 R2 (KB2264080 http://support.microsoft.com/kb/2264080.
Because the VM OS is Windows Server 2003, install the following updates:

Virtual Machine: Update the Integration Components in the VM 

See Also:

Originally posted at http://blogs.technet.com/b/tonyso/archive/2011/01/07/troubleshooting-hyper-v-vm-lost-network-connection.aspx

Leave a Comment
  • Please add 2 and 7 and type the answer here:
  • Post
Wiki - Revision Comment List(Revision Comment)
Sort by: Published Date | Most Recent | Most Useful
Comments
Page 1 of 1 (2 items)
Wikis - Comment List
Sort by: Published Date | Most Recent | Most Useful
Posting comments is temporarily disabled until 10:00am PST on Saturday, December 14th. Thank you for your patience.
Comments
  • tonysoper_MSFT edited Revision 2. Comment: CI Bug 10 fix

  • Fernando Lugão Veltem edited Revision 6. Comment: added toc

Page 1 of 1 (2 items)