Guidance When Connecting Windows 8 Beta to Windows Small Business Server 2011 Essentials, Windows Storage Server 2008 R2 Essentials, and Windows Home Server 2011

Guidance When Connecting Windows 8 Beta to Windows Small Business Server 2011 Essentials, Windows Storage Server 2008 R2 Essentials, and Windows Home Server 2011



Background


Windows 8 client Consumer Preview has been released, see following link for details:

http://windows.microsoft.com/en-US/windows-8/consumer-preview

The following are guidance for known issues you might encounter during beta testing windows 8 client, with Windows Small Business Server 2011 Essentials, Windows Storage Server 2008 R2 Essentials and Windows Home Server 2011.  For known issues with Windows Home Server V1, please see following article:
http://social.technet.microsoft.com/wiki/contents/articles/8497.known-issues-of-windows-8-client-connecting-to-windows-home-server-v1.aspx

Note this is  preview version of Windows 8 client, some known issues are still under investigation, further resolution will be published with final Windows 8 client version.


Issue 1


You need to Enable .net 3.5 in windows 8 in order to join WHS 2011

Symptom:


When you tried to join a windows 8 client machine to WHS 2011, you will see a message indicating an unexpected error.

Workaround:


You need to enable .Net Framework 3.5.

To enable .Net Framework 3.5 in Windows 8 32bit OS

1. Log on to the Widows 8 client machine.

2. Click Start, Type Control Panel, and then press Enter to open Control Panel.

3. Click Uninstall a program.

4. Click Turn Windows features on or off.

5. Check all .Net Framework 3.5 Items in pop-up Windows Features dialog.

6. Click OK to Search and download required files, and then complete .Net Framework 3.5 Components installation.

Not this issue only applies to WHS 2011.

Issue 2 


Power setting of Client backup doesn’t work.

Symptom:


When configuration client backup for windows 8 client, if user chooses to allow auto wake up for client backup, the setting will not take effect.

Issue 3


The thumbnail of picture folder is not displayed properly in Remote Web Access page.

Symptom


From the windows 8 client, open Remote web access site, navigate to picture page.

The  thumbnail  inside the the folder that should display the pictures can not be displayed.


Issue 4


When user tried to access the share folders from client computers that had joined home group, user still get prompts for credential.

Symptom


Join the window 8 client machine to home group,

Log on to the client, try to access the shared folder of the server, it still prompt user for credentials.

Note this issue only applied to WHS 2011.
Leave a Comment
  • Please add 1 and 2 and type the answer here:
  • Post
Wiki - Revision Comment List(Revision Comment)
Sort by: Published Date | Most Recent | Most Useful
Comments
  • Richard Mueller edited Revision 11. Comment: Removed (en-US) from title, fixed duplicate <a name> tags in HTML so TOC works, added tag

  • Ed Price - MSFT edited Revision 10. Comment: Title caps

  • Fernando Lugão Veltem edited Revision 9. Comment: added toc

Page 1 of 1 (3 items)
Wikis - Comment List
Sort by: Published Date | Most Recent | Most Useful
Posting comments is temporarily disabled until 10:00am PST on Saturday, December 14th. Thank you for your patience.
Comments
  • Additionally to the workaround on Issue 1 explained in this article, make sure you download the clinet connector software to the W8 client's Desktop first. Then set it to Windows 7 compatibility mode (right-click, compatibility tab) before executing the connector.

  • Even if you don't use Home Groups on your network, you may still have issues connecting to shared folders on the server if you use linked Microsoft ID to log into Windows 8 (which will be the preferred way for most users who wish to enable roaming and cloud syncing on Windows 8).  This is because Windows 8 creates local proxy accounts for each linked Microsoft ID, and these proxy accounts do not have the same names as the user accounts on the server.

  • Issue #2 - On the test system I have Win8 CP running I was able to get around the “auto wake-up” problem by setting the Sleep time to “never”; and the Hibernate time to “30 minutes” under Power Settings.

  • Gary: All you have to do is add your server credentials to your account.  This can be done under Control Panel -> Credential Manager -> Windows Credentials -> Add a Windows Credential.  Type in the name of your server, username & password, and boom.  Instant access.  No problems accessing any of the resources on my WHS2011 once I did that.  :)

  • If anyone can help me i  would greatly appreciate it..... i have tried installing .net 3.5 on windows 8 and running setup in compat mode with admin rights but the damn connector software will keep exiting with the unexpected error. it is driving me NUTS!!!! i have also reinstalled WHS2011 at least twice. i am running WHS2011 as a Virtual Machine in HyperV

  • I'm running Win 8 RP 64 and had to turn off Windows Firewall (private network only) temporarily to get the Connector to install.  Without this it kept erroring out with "Unexpected Error".

  • Fernando Lugão Veltem edited Revision 9. Comment: added toc

  • Ed Price - MSFT edited Revision 10. Comment: Title caps

  • I had no problem with my windows 8 but had to reload my WHS 2011 server. then my windows 8 machine again OK but now it wil have nothing to do with Windows 7 machines or partitions.

  • Can anyone successfully get W8 new UI picture and video app to view stuff on your WHS2011 box?

  • Helped me to solve one of my first Windows 8 (final) Problems (my problem is described in issue 1 above)

  • Helped me to solve one of my first Windows 8 (final) problems (my problem is described in issue 1 above)

  • Thanks for the tip, Theo. Will take note of that.

  • I had the same problem. Don't know to much of WHS 2011 and W8. Problem remained, tried everything I read on the web. And yesterday all of a sudden I got my W8 connected to my server. Still not sure what solved the problem, but I created a networkshare or disk and I made some serverfiles offline available via synchronisation on my W8 machine.For this I enabled offlinefiles on both the WHS and W8 machine. And then it worked. After this the offline option was no longer needed, so  i turned it off. It still works okay. Maybe this is of some help.

  • Hello, I followed the link here from this article:

    blogs.windows.com/.../connecting-windows-8-consumer-preview-with-windows-home-server.aspx

    I was looking for assistance with WHS V1. But the link in the above article for the V1 wiki takes me to a page that displays: Not Found: Resource Not Found

    I really need a fix for "When the Windows 8 client computer is connected to Windows Home Server, if you use Windows Live ID to log on, you need to provide additional user credentials for accessing the server resources."

    Can someone help?

Page 1 of 2 (18 items) 12